1
Completed

Prevent truncation of large clipboard entries

Some text files I copy to my PC clipboard are obviously too big to sync with my phone clipboard, which is understandable. However the problem I have is that as soon as Join tries to sync it then my PC clipboard is truncated so it no longer contains the whole text file, so I have a window of about 3 seconds to do a copy and paste before Join modifies the PC clipboard and deletes everything beyond the first 5000 characters.

I never need to copy such large amounts of text between devices, so a simple "if clipboard contents < 5000 chars sync between devices, else do nothing" logic would be a perfect fix for me. 

2 replies

Yes it only happens when automatic clipboard sync is enabled in both directions. I've done a bit more testing and here is what seems to be happening. I've tried using a Samsung S6 running Lollipop and a OnePlus 3 running Nougat

When I copy the text file to PC clipboard then only the first 5000 characters are sent to both Android device clipboards (tested independently, not both syncing together). The Android device then syncs this truncated clipboard back with the PC clipboard so now the PC clipboard also only contains 5000 characters.

If I only enable one way sync from Android device to PC then on both the OnePlus and the S6 I can copy more than 5000 characters to Android clipboard and they will all be synced with PC clipboard.

If I enable one way sync from Chrome to either Android device only 5000 characters are sent to the Android device but the PC clipboard remains OK

If I enable one way sync between the S6 and the OnePlus in either direction only the first 5000 characters are sent to the other device.

I've tried with and without encryption, notifications, toasts, accessibility enabled and none of those settings make any difference to the outcome.

 

Ok! Thank you! :) That extra info was exactly what I needed to fix it!

 

Here's the fixed version: https://www.dropbox.com/s/bfjh0oaeri6cqfm/Join.apk?dl=1

 

Hope this helps!

Thanks but I cannot reproduce this issue. Can you confirm that this only happens if automatic clipboard sync is enabled in Chrome?